summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rails-dom-testing')
-rw-r--r--dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..b920cebb02d7
--- /dev/null
+++ b/dev-ruby/rails-dom-testing/rails-dom-testing-2.0.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compare doms and assert certain elements exists in doms using Nokogiri"
+HOMEPAGE="https://github.com/kaspth/rails-dom-testing"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activesupport-4.2.0:*
+ >=dev-ruby/nokogiri-1.6"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}