summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rake/rake-11.1.1.ebuild')
-rw-r--r--dev-ruby/rake/rake-11.1.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/rake/rake-11.1.1.ebuild b/dev-ruby/rake/rake-11.1.1.ebuild
deleted file mode 100644
index 93013f79e4c1..000000000000
--- a/dev-ruby/rake/rake-11.1.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc TODO"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="Make-like scripting in Ruby"
-HOMEPAGE="https://github.com/ruby/rake"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-DEPEND+=" app-arch/gzip"
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.8 )"
-
-all_ruby_compile() {
- if use doc; then
- rdoc --title "Rake - Ruby Make" --main README.rdoc --out html lib *.rdoc doc/*/*.rdoc || die
- fi
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'gem "minitest", "~>5.8"; require "minitest/autorun"; Dir["test/test_*.rb"].each{|f| require f}' || die
-}
-
-all_ruby_install() {
- ruby_fakegem_binwrapper rake
-
- if use doc; then
- pushd html
- dohtml -r *
- popd
- fi
-
- doman doc/rake.1
-
- newbashcomp "${FILESDIR}"/rake.bash-completion ${PN}
-}