summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/regexp_parser/regexp_parser-1.8.2.ebuild')
-rw-r--r--dev-ruby/regexp_parser/regexp_parser-1.8.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/regexp_parser/regexp_parser-1.8.2.ebuild b/dev-ruby/regexp_parser/regexp_parser-1.8.2.ebuild
new file mode 100644
index 000000000000..9a339fd368c9
--- /dev/null
+++ b/dev-ruby/regexp_parser/regexp_parser-1.8.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="test:full"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="regexp_parser.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for tokenizing, lexing, and parsing Ruby regular expressions"
+HOMEPAGE="https://github.com/ammar/regexp_parser"
+SRC_URI="https://github.com/ammar/regexp_parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE=""
+
+DEPEND+=" =dev-util/ragel-6*"
+
+ruby_add_bdepend "dev-ruby/rake
+ test? ( dev-ruby/regexp_property_values dev-ruby/rspec:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake ragel:rb || die
+}