summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/regexp_property_values')
-rw-r--r--dev-ruby/regexp_property_values/Manifest1
-rw-r--r--dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/regexp_property_values/Manifest b/dev-ruby/regexp_property_values/Manifest
index 994f22a41b4e..f06e1574995e 100644
--- a/dev-ruby/regexp_property_values/Manifest
+++ b/dev-ruby/regexp_property_values/Manifest
@@ -1,2 +1,3 @@
DIST regexp_property_values-0.3.4.tar.gz 11273 BLAKE2B a52ab11676b58a752741240912da5fa312661a583dd74a4321f8184fef2864c74e0d5f709cb68e3ce64a3e19e9320305e80bf7614a40142c4855ccec1c40b5a5 SHA512 01ca50f831bf3364e38559e06cb54faef59fdb0b995a6bfa0aaa3943591d98f97939a47911bf8b075b34b3c401b5de51e42a71088400112ee8afd8d39f164465
DIST regexp_property_values-0.3.5.tar.gz 11410 BLAKE2B adcf7848af9df53707a878ee35443583b03f96f60f9b23fd5f146e81b4b12a4e3ada2c48d6509b15c848b15c668d9430ef93b34f08491ce13249ec458b2be0eb SHA512 5ac91331deb12fd77ee6a5ca8f942c2b2ea0ccb42bc63548444ecfe85c3a60bad385831b408f21c848f0c0ac2db3c68f8391fd68074acb0187ae9de51ca76e47
+DIST regexp_property_values-1.0.0.tar.gz 12884 BLAKE2B 82f63d21a1e1508cef79afc2f1b5cca842c1e5bc96b197efa90ec0d02e7bd213cc67ae99f4f71cae6e632e0804fa2d6e935c7d30f27a940c767f5a83dd9edd21 SHA512 f51946d93c255c3b51bfb8055d2c0548c9656db9f208de74b569df8799fa97712a76b509546e149f71e3176ae0e979f295b225c171cedc687e1871f204c1e0d3
diff --git a/dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild b/dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild
new file mode 100644
index 000000000000..10afef7a1307
--- /dev/null
+++ b/dev-ruby/regexp_property_values/regexp_property_values-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="See which property values are supported by the regular expression engine"
+HOMEPAGE="https://github.com/janosch-x/regexp_property_values"
+SRC_URI="https://github.com/janosch-x/regexp_property_values/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid dependency on character_set which would lead to circular
+ # dependencies.
+ sed -i -e '/returns a CharacterSet/askip "gentoo circular dependencies"' spec/regexp_property_values/value_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/regexp_property_values extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/regexp_property_values V=1
+ cp ext/regexp_property_values/regexp_property_values.so lib/regexp_property_values/ || die
+}