summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rex-encoder/rex-encoder-0.1.4.ebuild')
-rw-r--r--dev-ruby/rex-encoder/rex-encoder-0.1.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rex-encoder/rex-encoder-0.1.4.ebuild b/dev-ruby/rex-encoder/rex-encoder-0.1.4.ebuild
new file mode 100644
index 000000000000..00d68b909031
--- /dev/null
+++ b/dev-ruby/rex-encoder/rex-encoder-0.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+# Specs are not provided in the gem
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="provides the basis for all of the polymorphic encoders that Metasploit uses"
+HOMEPAGE="https://rubygems.org/gems/rex-encoder"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test"
+
+ruby_add_rdepend "dev-ruby/metasm:*
+ dev-ruby/rex-arch
+ dev-ruby/rex-text"
+
+all_ruby_prepare() {
+ sed -i '/bundler/d' Rakefile
+}