summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rkelly-remix')
-rw-r--r--dev-ruby/rkelly-remix/rkelly-remix-0.0.7-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ruby/rkelly-remix/rkelly-remix-0.0.7-r1.ebuild b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..ab8dfa4bf714
--- /dev/null
+++ b/dev-ruby/rkelly-remix/rkelly-remix-0.0.7-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RKelly Remix is a fork of the RKelly JavaScript parser"
+HOMEPAGE="https://github.com/nene/rkelly-remix"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+each_ruby_test() {
+ ${RUBY} -S testrb-2 -Ilib:. test/test_*.rb test/*/test_*.rb || die
+}