summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rouge/rouge-3.23.0.ebuild')
-rw-r--r--dev-ruby/rouge/rouge-3.23.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/rouge/rouge-3.23.0.ebuild b/dev-ruby/rouge/rouge-3.23.0.ebuild
deleted file mode 100644
index 7e43cc39b023..000000000000
--- a/dev-ruby/rouge/rouge-3.23.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_RECIPE_DOC="yard"
-
-RUBY_FAKEGEM_GEMSPEC="rouge.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Yet-another-markdown-parser using a strict syntax definition in pure Ruby"
-HOMEPAGE="https://github.com/jneen/rouge"
-SRC_URI="https://github.com/jneen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-
-SLOT="2"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_bdepend "doc? ( dev-ruby/redcarpet )
- test? ( dev-ruby/minitest-power_assert )
- dev-ruby/yard
-"
-
-ruby_add_rdepend "dev-ruby/redcarpet"
-
-all_ruby_prepare() {
- rm -f tasks/{check/style,update/changelog}.rake || die
-
- sed -i -e '/bundler/I s:^:#: ; 5irequire "minitest-power_assert"' spec/spec_helper.rb || die
- sed -i -e '/\(changelog\|bundler\|rubocop\)/ s:^:#: ; 1irequire "pathname"' Rakefile || die
-}