summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rqrcode_core/rqrcode_core-1.2.0.ebuild')
-rw-r--r--dev-ruby/rqrcode_core/rqrcode_core-1.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rqrcode_core/rqrcode_core-1.2.0.ebuild b/dev-ruby/rqrcode_core/rqrcode_core-1.2.0.ebuild
new file mode 100644
index 000000000000..ce663572b3d0
--- /dev/null
+++ b/dev-ruby/rqrcode_core/rqrcode_core-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rqrcode_core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for encoding QR Codes"
+HOMEPAGE="https://github.com/whomwah/rqrcode_core/"
+SRC_URI="https://github.com/whomwah/rqrcode_core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/test_helper.rb || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/*_test.rb"].each {|f| require f}' || die
+}