summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild')
-rw-r--r--dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..fa5b616c6674
--- /dev/null
+++ b/dev-ruby/ruby-opengl/ruby-opengl-0.10.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+# Two tests fails but the README already indicates that this may not
+# work. Additionally these tests require access to video devices such as
+# /dev/nvidiactl.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_NAME="opengl"
+
+RUBY_FAKEGEM_EXTRADOC="History.md README.rdoc"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/opengl/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=(lib/opengl)
+
+inherit ruby-fakegem
+
+DESCRIPTION="OpenGL / GLUT bindings for ruby"
+HOMEPAGE="https://github.com/larskanis/opengl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ppc64 x86"
+
+IUSE=""
+
+DEPEND+=" virtual/opengl
+ media-libs/freeglut"
+RDEPEND+=" virtual/opengl
+ media-libs/freeglut"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}