summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r2.ebuild')
-rw-r--r--dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r2.ebuild b/dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r2.ebuild
new file mode 100644
index 000000000000..e13ac8a0f1c0
--- /dev/null
+++ b/dev-ruby/ruby-rc4/ruby-rc4-0.1.5-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby implementation of the Rc4 algorithm"
+HOMEPAGE="https://github.com/caiges/Ruby-RC4"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/"README"/"README.md"/' Rakefile || die
+}