summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby_gntp')
-rw-r--r--dev-ruby/ruby_gntp/ruby_gntp-0.3.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby_gntp/ruby_gntp-0.3.4-r1.ebuild b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..5fe27dde44c9
--- /dev/null
+++ b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for GNTP(Growl Notification Transport Protocol)"
+HOMEPAGE="https://github.com/snaka/ruby_gntp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rr )"
+
+all_ruby_prepare() {
+ mv test spec || die
+ sed -i -e "s/Spec::Runner/RSpec/" \
+ -e "s#\.\./lib/##"\
+ spec/ruby_gntp_spec.rb || die
+
+}