summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/slim')
-rw-r--r--dev-ruby/slim/slim-3.0.7.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-ruby/slim/slim-3.0.7.ebuild b/dev-ruby/slim/slim-3.0.7.ebuild
index 7fb563e6a8e8..f2249a699373 100644
--- a/dev-ruby/slim/slim-3.0.7.ebuild
+++ b/dev-ruby/slim/slim-3.0.7.ebuild
@@ -33,10 +33,11 @@ all_ruby_prepare() {
# This sinatra code expects tests to be installed but we strip those.
sed -i -e "s/require 'sinatra'/require 'bogussinatra'/" Rakefile || die
- # Avoid tests for things we don't have.
+ # Avoid tests for things we don't have. The builder test does not pass with tilt 2.x
sed -i -e '/test_wip_render_with_asciidoc/,/^ end/ s:^:#:' \
-e '/test_render_with_wiki/,/^ end/ s:^:#:' \
-e '/test_render_with_creole/,/^ end/ s:^:#:' \
+ -e '/test_render_with_builder/,/^ end/ s:^:#:' \
-e '/test_render_with_org/,/^ end/ s:^:#:' test/core/test_embedded_engines.rb || die
}