summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/slop/slop-3.6.0.ebuild')
-rw-r--r--dev-ruby/slop/slop-3.6.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/slop/slop-3.6.0.ebuild b/dev-ruby/slop/slop-3.6.0.ebuild
new file mode 100644
index 000000000000..9112ca4d8824
--- /dev/null
+++ b/dev-ruby/slop/slop-3.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}