summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/spring/spring-2.1.1.ebuild')
-rw-r--r--dev-ruby/spring/spring-2.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/spring/spring-2.1.1.ebuild b/dev-ruby/spring/spring-2.1.1.ebuild
new file mode 100644
index 000000000000..425e21159622
--- /dev/null
+++ b/dev-ruby/spring/spring-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_GEMSPEC="spring.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rails application preloader"
+HOMEPAGE="https://github.com/rails/spring"
+SRC_URI="https://github.com/rails/spring/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-4.2:*"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ sed -i -e '/files/d' \
+ -e '/bump/d' ${PN}.gemspec || die
+ sed -i -e '/bump/d' Rakefile || die
+}