summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/term-ansicolor/term-ansicolor-1.3.0-r1.ebuild')
-rw-r--r--dev-ruby/term-ansicolor/term-ansicolor-1.3.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/term-ansicolor/term-ansicolor-1.3.0-r1.ebuild b/dev-ruby/term-ansicolor/term-ansicolor-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..3662f014ff03
--- /dev/null
+++ b/dev-ruby/term-ansicolor/term-ansicolor-1.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="term-ansicolor.gemspec"
+
+# don't install a cdiff wrapper, collides with app-misc/colordiff (bug
+# #310073).
+RUBY_FAKEGEM_BINWRAP="decolor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Small Ruby library that colors strings using ANSI escape sequences"
+HOMEPAGE="https://flori.github.io/term-ansicolor/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-1.0"
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/*_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}