summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/test_construct/test_construct-2.0.1.ebuild')
-rw-r--r--dev-ruby/test_construct/test_construct-2.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/test_construct/test_construct-2.0.1.ebuild b/dev-ruby/test_construct/test_construct-2.0.1.ebuild
new file mode 100644
index 000000000000..e75210d29847
--- /dev/null
+++ b/dev-ruby/test_construct/test_construct-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Creates temporary files and directories for testing"
+HOMEPAGE="https://github.com/bhb/test_construct"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-5.0.8
+ >=dev-ruby/mocha-0.14.0
+ dev-ruby/rspec:3
+)"
+
+all_ruby_prepare () {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}