summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild')
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild
deleted file mode 100644
index 5bcf4d8e8424..000000000000
--- a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby20"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="W3C HTML Tidy library implemented as a Ruby extension"
-HOMEPAGE="https://github.com/carld/tidy"
-
-LICENSE="HTML-Tidy"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-all_ruby_prepare() {
- mkdir lib || die
-
- # Remove reference to rspec 1
- sed -i -e '/spec/d' spec/spec_helper.rb || die
-
- # Avoid spec that needs network connectivity.
- rm spec/tidy/remote_uri_spec.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/tidy extconf.rb || die "Unable to configure extension."
-}
-
-each_ruby_compile() {
- emake -Cext/tidy V=1
- cp ext/tidy/tidy$(get_modname) lib/ || die "Unable to copy extension."
-}