summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tins')
-rw-r--r--dev-ruby/tins/Manifest1
-rw-r--r--dev-ruby/tins/tins-1.20.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/tins/Manifest b/dev-ruby/tins/Manifest
index 430bc2d433dc..2557d95c7479 100644
--- a/dev-ruby/tins/Manifest
+++ b/dev-ruby/tins/Manifest
@@ -1 +1,2 @@
DIST tins-1.20.2.gem 305664 BLAKE2B 37d206664077aa1ba8bac395e076b448797c9d73f46950ff339834b55cb1eaa36e1cdd47a9795d783671a8ef393f6059578ed684240de377ec8824c2468f5014 SHA512 c6c7694ddadf0cf46176a1fabda8ffc2d6b098ca6ed4d568f30c66100a2f55c25ce83c09e8ba379ee6c49dd68d6f1572f17f70f9666628c1fe5225fcc9d7b788
+DIST tins-1.20.3.gem 305664 BLAKE2B 26c78cf94acba6651c631b274a98cc7e19d3e215a450d255886d201c5bf94c343141edeb03456a178943cf70efbc9b75ea12cc2ccaec5c929fe5b2c08e918d2c SHA512 f5f723402096e869a8e44e64db9dcd0be4620812f0b5cc291df79010fcb87774ad56298de328242c96ce9dca64f7313271b9fec8cff758a6b3b689bec17c965d
diff --git a/dev-ruby/tins/tins-1.20.3.ebuild b/dev-ruby/tins/tins-1.20.3.ebuild
new file mode 100644
index 000000000000..19bbb25c440d
--- /dev/null
+++ b/dev-ruby/tins/tins-1.20.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}