summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/typeprof/typeprof-0.21.7.ebuild')
-rw-r--r--dev-ruby/typeprof/typeprof-0.21.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/typeprof/typeprof-0.21.7.ebuild b/dev-ruby/typeprof/typeprof-0.21.7.ebuild
new file mode 100644
index 000000000000..abc0af17aad3
--- /dev/null
+++ b/dev-ruby/typeprof/typeprof-0.21.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="typeprof.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performs a type analysis of non-annotated Ruby code"
+HOMEPAGE="https://github.com/ruby/typeprof"
+SRC_URI="https://github.com/ruby/typeprof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/rbs-1.8.1"
+
+all_ruby_prepare() {
+ # Avoid tests that download live code using git
+ rm -r test/typeprof/{goodcheck,diff-lcs}_test.rb || die
+
+ sed -i -e "s:_relative ': './:" -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}