summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/vlad/vlad-2.6.5.ebuild')
-rw-r--r--dev-ruby/vlad/vlad-2.6.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/vlad/vlad-2.6.5.ebuild b/dev-ruby/vlad/vlad-2.6.5.ebuild
new file mode 100644
index 000000000000..7dd1ea2d83f3
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.6.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy"
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-3.13
+ test? ( >=dev-ruby/minitest-5.7 )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.3"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' -e '/rubyforge/ s:^:#:' Rakefile || die
+}