summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/jwt/Manifest1
-rw-r--r--dev-ruby/jwt/jwt-2.1.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/jwt/Manifest b/dev-ruby/jwt/Manifest
index 996f46fdd2ce..688e41bdf270 100644
--- a/dev-ruby/jwt/Manifest
+++ b/dev-ruby/jwt/Manifest
@@ -1,2 +1,3 @@
DIST jwt-1.5.6.tar.gz 28586 BLAKE2B d1fa2e735cf93126866c7a5eca14d63ee2646a66b9759fa59ec3191544efb2e0f502c7474e41a1b0d494ed8d692462db64efd718b8c6fa8acb4fcd9b58ab1c32 SHA512 f112bb815ef1af1f77d082574f5157f33469c2caba88716aa16b20dc48d279f8579730f75db81aa31480d6edd5deaa110adbaf3f52372b0397d5822a964a759e
DIST jwt-2.0.0.tar.gz 32205 BLAKE2B ba356abd8bc37e819576485e381eb6025324ca3a8872a6d64d0e2a2ff51dd11a804fa904384c47d58b6dee46331fa7f6ca19feb042d3e65de30583211ff7af17 SHA512 d194e06df17edfbde49d9ae6caad5e220f602ce722ae4361a5118024e08dcaddccc71a8fbac99e75ce3b19033e6368825914eed3e91e402b2cf208ebaabf23a5
+DIST jwt-2.1.0.tar.gz 34188 BLAKE2B 0022dbb76cd8570aee84b6590f24639320977ae8d6d5fa53ef1d260da12bc732f9fdc01d59f6c994dc36642a7b67786b607ae76aca8044b7d5f5c60dc300966a SHA512 ad65b6ddd5fb7f33efe0036103f8f7482fd35090b8545219141e8885298fb4809d2386fd6e986c9bca0f85c823c9d4a6500785c0c5964db22d023a99c603ec47
diff --git a/dev-ruby/jwt/jwt-2.1.0.ebuild b/dev-ruby/jwt/jwt-2.1.0.ebuild
new file mode 100644
index 000000000000..844582f34207
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.configure/,/^end/ s:^:#:' \
+ -e '/codeclimate/I s:^:#:' \
+ -e '/codacy/I s:^:#:' \
+ spec/spec_helper.rb || die
+}