summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/gauche/gauche-0.9.6-r1.ebuild')
-rw-r--r--dev-scheme/gauche/gauche-0.9.6-r1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-scheme/gauche/gauche-0.9.6-r1.ebuild b/dev-scheme/gauche/gauche-0.9.6-r1.ebuild
deleted file mode 100644
index 072a1b05fc6e..000000000000
--- a/dev-scheme/gauche/gauche-0.9.6-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools eapi7-ver
-
-MY_P="${P^g}"
-
-DESCRIPTION="A Unix system friendly Scheme Interpreter"
-HOMEPAGE="http://practical-scheme.net/gauche/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
-
-LICENSE="BSD"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="ipv6 libressl mbedtls test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="sys-libs/gdbm
- mbedtls? ( net-libs/mbedtls:= )"
-DEPEND="${RDEPEND}
- test? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl:0 )
- )"
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-gauche.m4.patch
- "${FILESDIR}"/${PN}-ext-ldflags.patch
- "${FILESDIR}"/${PN}-xz-info.patch
- "${FILESDIR}"/${P}-rfc.tls.patch
-)
-DOCS=( AUTHORS ChangeLog HACKING README )
-
-src_prepare() {
- default
- use ipv6 && sed -i "s/ -4//" ext/tls/ssltest-mod.scm
-
- eautoconf
-}
-
-src_configure() {
- econf \
- $(use_enable ipv6) \
- --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
- --with-libatomic-ops=no \
- --with-slib="${EPREFIX}"/usr/share/slib \
- --with-tls=axtls$(usex mbedtls ',mbedtls' '')
-}
-
-src_test() {
- emake -j1 -s check
-}
-
-src_install() {
- emake DESTDIR="${D}" install-pkg install-doc
- einstalldocs
-}