summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/xdgdirs/xdgdirs-2.2.ebuild')
-rw-r--r--dev-scheme/xdgdirs/xdgdirs-2.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-scheme/xdgdirs/xdgdirs-2.2.ebuild b/dev-scheme/xdgdirs/xdgdirs-2.2.ebuild
new file mode 100644
index 000000000000..eb024b533f87
--- /dev/null
+++ b/dev-scheme/xdgdirs/xdgdirs-2.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Displays names/values of XDG Basedir variables"
+HOMEPAGE="https://www.gnuvola.org/software/xdgdirs/"
+SRC_URI="https://www.gnuvola.org/software/xdgdirs/${P}.tar.xz"
+
+LICENSE="GPL-3+ FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-scheme/guile-1.8"
+DEPEND="test? ( ${RDEPEND} )"
+
+src_test() {
+ GUILE_AUTO_COMPILE=0 emake check
+}