summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tkdnd/tkdnd-2.9.2.ebuild')
-rw-r--r--dev-tcltk/tkdnd/tkdnd-2.9.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tcltk/tkdnd/tkdnd-2.9.2.ebuild b/dev-tcltk/tkdnd/tkdnd-2.9.2.ebuild
new file mode 100644
index 000000000000..bdb92d663891
--- /dev/null
+++ b/dev-tcltk/tkdnd/tkdnd-2.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-release-test-v${PV}
+
+DESCRIPTION="Adds native drag & drop capabilities to tk toolkit"
+HOMEPAGE="http://www.ellogon.org/petasis/tcltk-projects/tkdnd/"
+SRC_URI="https://github.com/petasis/tkdnd/archive/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug threads X"
+
+DEPEND="dev-lang/tk:="
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${PN}-${MY_P}
+
+RESTRICT="test"
+
+src_prepare() {
+ sed \
+ -e 's:-O2::g' \
+ -e 's:-fomit-frame-pointer::g' \
+ -e 's:-pipe::g' \
+ -i configure tclconfig/tcl.m4 || die
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_with X x) \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}