summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/snack/files/alsa-undef-sym.patch6
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r7.ebuild96
2 files changed, 99 insertions, 3 deletions
diff --git a/dev-tcltk/snack/files/alsa-undef-sym.patch b/dev-tcltk/snack/files/alsa-undef-sym.patch
index 77a222754fe1..c46b9371c752 100644
--- a/dev-tcltk/snack/files/alsa-undef-sym.patch
+++ b/dev-tcltk/snack/files/alsa-undef-sym.patch
@@ -1,5 +1,5 @@
---- unix/jkAudIO_alsa.c 2005-12-14 12:29:38.000000000 +0100
-+++ unix/jkAudIO_alsa.c 2008-09-01 22:51:20.000000000 +0200
+--- a/unix/jkAudIO_alsa.c 2005-12-14 12:29:38.000000000 +0100
++++ b/unix/jkAudIO_alsa.c 2008-09-01 22:51:20.000000000 +0200
@@ -49,6 +49,8 @@
static int minNumChan = 1;
@@ -46,4 +46,4 @@
+ return (played);
}
- void \ No newline at end of file
+ void
diff --git a/dev-tcltk/snack/snack-2.2.10-r7.ebuild b/dev-tcltk/snack/snack-2.2.10-r7.ebuild
new file mode 100644
index 000000000000..964ec12d5b46
--- /dev/null
+++ b/dev-tcltk/snack/snack-2.2.10-r7.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit autotools distutils-r1 multilib
+
+DESCRIPTION="The Snack Sound Toolkit (Tcl)"
+HOMEPAGE="http://www.speech.kth.se/snack/"
+SRC_URI="http://www.speech.kth.se/snack/dist/${PN}${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+SLOT="0"
+IUSE="alsa examples python vorbis"
+
+RESTRICT="test" # Bug 78354
+
+DEPEND="
+ dev-lang/tcl:0=
+ dev-lang/tk:0=
+ alsa? ( media-libs/alsa-lib )
+ python? ( ${PYTHON_DEPS} )
+ vorbis? ( media-libs/libvorbis )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}${PV}/unix"
+
+PATCHES=(
+ "${FILESDIR}"/alsa-undef-sym.patch
+ "${FILESDIR}"/${P}-CVE-2012-6303-fix.patch
+ )
+
+HTML_DOCS="${WORKDIR}/${PN}${PV}/doc/*"
+
+src_prepare() {
+ # adds -install_name (soname on Darwin)
+ [[ ${CHOST} == *-darwin* ]] && PATCHES+=( "${FILESDIR}"/${P}-darwin.patch )
+
+ sed \
+ -e "s:ar cr:$(tc-getAR) cr:g" \
+ -e "s:-O:${CFLAGS}:g" \
+ -i Makefile.in || die
+
+ cd ..
+
+ default
+
+ sed \
+ -e 's|^\(#define roundf(.*\)|//\1|' \
+ -i generic/jkFormatMP3.c || die
+}
+
+src_configure() {
+ local myconf=""
+
+ use alsa && myconf+=" --enable-alsa"
+
+ use vorbis && \
+ myconf+=" --with-ogg-include="${EPREFIX}"/usr/include"
+ myconf+=" --with-ogg-lib="${EPREFIX}"/usr/$(get_libdir)"
+
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --includedir="${EPREFIX}"/usr/include \
+ --with-tcl="${EPREFIX}"/usr/$(get_libdir) \
+ --with-tk="${EPREFIX}"/usr/$(get_libdir) \
+ $myconf
+}
+
+src_compile() {
+ default
+}
+
+HTMML_DOCS=""
+
+src_install() {
+ default
+
+ if use python ; then
+ cd "${S}"/../python || die
+ distutils-r1_src_install
+ fi
+
+ cd "${S}"/.. || die
+
+ if use examples ; then
+ docinto examples
+ sed -i -e 's/wish[0-9.]+/wish/g' demos/tcl/* || die
+ dodoc -r demos/tcl
+
+ use python && dodoc -r demos/python
+ fi
+}