summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bdelta')
-rw-r--r--dev-util/bdelta/bdelta-0.3.1-r1.ebuild (renamed from dev-util/bdelta/bdelta-0.3.1.ebuild)16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-util/bdelta/bdelta-0.3.1.ebuild b/dev-util/bdelta/bdelta-0.3.1-r1.ebuild
index edb6de3eca39..c199f1524f7d 100644
--- a/dev-util/bdelta/bdelta-0.3.1.ebuild
+++ b/dev-util/bdelta/bdelta-0.3.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://github.com/jjwhitney/BDelta.git"
@@ -11,7 +11,7 @@ else
UNPACKER_ECLASS="vcs-snapshot"
fi
-inherit eutils multilib toolchain-funcs ${UNPACKER_ECLASS}
+inherit toolchain-funcs ${UNPACKER_ECLASS}
if [[ -z ${LIVE_EBUILD} ]]; then
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-linux"
@@ -19,16 +19,16 @@ if [[ -z ${LIVE_EBUILD} ]]; then
fi
DESCRIPTION="Binary Delta - Efficient difference algorithm and format"
-HOMEPAGE="http://bdelta.org"
+HOMEPAGE="https://github.com/jjwhitney/BDelta"
SLOT="0"
LICENSE="MPL-2.0"
IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/${P}-soname.patch
- epatch "${FILESDIR}"/${P}-gcc-6.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-soname.patch
+ "${FILESDIR}"/${P}-gcc-6.patch
+)
src_compile() {
emake -C src \