summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/catalyst')
-rw-r--r--dev-util/catalyst/Manifest2
-rw-r--r--dev-util/catalyst/catalyst-2.0.16.ebuild111
-rw-r--r--dev-util/catalyst/catalyst-2.0.17.ebuild111
-rw-r--r--dev-util/catalyst/catalyst-2.0.18.ebuild111
4 files changed, 0 insertions, 335 deletions
diff --git a/dev-util/catalyst/Manifest b/dev-util/catalyst/Manifest
index d7654b41fdda..822c3d4e4906 100644
--- a/dev-util/catalyst/Manifest
+++ b/dev-util/catalyst/Manifest
@@ -1,3 +1 @@
-DIST catalyst-2.0.16.tar.bz2 878929 SHA256 4578cbbc36a5d913b51967faad6feb9b8bb10a04794fe44e73b71790fa389142 SHA512 460ee4c996a7197f2d3e2504ef5ff205c74c0e7ca763a67dc57932a8df6199334fef3b234d90da1717d3f59b36081a29c768a864efa82129cd4f6e2de34ac3a8 WHIRLPOOL e43861bcb7286f85e8d0857d32f4e0ba9f39eea5bae2eac05e0b9e782ee2edad2a8171e1a0ea451c7ee67b21f2210f8ff3f2a9e37c16d16552c6c46e74637233
-DIST catalyst-2.0.17.tar.bz2 861341 SHA256 5f4142598d921e5174ff06f9571856760a324e79db5f3b63caf0d1a16adc813c SHA512 9d7b9ad383dcc5d4ba058596c0b607eb9601b28025d9300f63e68d78cbd5bca8fa3f3e03a81dc6b233021e773ba4301df0bf5cec51ca4368eb3577a68d33a92c WHIRLPOOL e97fc120141cc4f9f5c297652d8b43313780f615429c0eb3d9b85cba40aeca01dcbc6efb0f8d388cc5e7debabb2563cfc9b5a5aa00e3d00d306aed0f799fc642
DIST catalyst-2.0.18.tar.bz2 861398 SHA256 f3c2583fb8da425a9c57d3a00aac559e6bfde5951f1c7ef30ddf4fa00d6bedbd SHA512 5a1408ffe06ce5c06a6bca8f0e3ecd91c17cdc36e2dfa37881d843432bdfe987fd2cfd988cd5719bdf378c18c2e79ee59e281c3b4dba4ae9edfc2dd654b8ee4a WHIRLPOOL 73abb541bd9984e26e43dbeee3156ca84104aedfe16a027b97790274aaffa8678a29677da4ada908fe9c2184268eb9c266a8961a5e0681fccc463c47a6d83542
diff --git a/dev-util/catalyst/catalyst-2.0.16.ebuild b/dev-util/catalyst/catalyst-2.0.16.ebuild
deleted file mode 100644
index 0bd3e47ff8b5..000000000000
--- a/dev-util/catalyst/catalyst-2.0.16.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-if [[ ${PV} == *9999* ]]; then
- SRC_ECLASS="git-2"
- EGIT_REPO_URI="anongit.gentoo.org/proj/catalyst.git"
- EGIT_MASTER="master"
- SRC_URI=""
- KEYWORDS=""
- S="${WORKDIR}/${PN}"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~dolsen/releases/catalyst/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-single-r1 ${SRC_ECLASS}
-
-DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="https://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ccache kernel_linux"
-
-DEPEND="
- app-text/asciidoc
- ${PYTHON_DEPS}
-"
-RDEPEND="
- app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- amd64? ( >=sys-boot/syslinux-3.72 )
- ia64? ( sys-fs/dosfstools )
- x86? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
- ${PYTHON_DEPS}
-"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
-
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
-
- python-single-r1_pkg_setup
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
-
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
-
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
-
- # Here is where we actually enable ccache
- use ccache && \
- sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
- files/catalyst.conf
-
- sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- files/catalyst.conf
-
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README AUTHORS
- doman files/catalyst.1 files/catalyst-spec.5
-
- python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
- python_optimize "${ED}"
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "https://www.gentoo.org/proj/en/releng/catalyst/index.xml"
-}
diff --git a/dev-util/catalyst/catalyst-2.0.17.ebuild b/dev-util/catalyst/catalyst-2.0.17.ebuild
deleted file mode 100644
index 0bd3e47ff8b5..000000000000
--- a/dev-util/catalyst/catalyst-2.0.17.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-if [[ ${PV} == *9999* ]]; then
- SRC_ECLASS="git-2"
- EGIT_REPO_URI="anongit.gentoo.org/proj/catalyst.git"
- EGIT_MASTER="master"
- SRC_URI=""
- KEYWORDS=""
- S="${WORKDIR}/${PN}"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~dolsen/releases/catalyst/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-single-r1 ${SRC_ECLASS}
-
-DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="https://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ccache kernel_linux"
-
-DEPEND="
- app-text/asciidoc
- ${PYTHON_DEPS}
-"
-RDEPEND="
- app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- amd64? ( >=sys-boot/syslinux-3.72 )
- ia64? ( sys-fs/dosfstools )
- x86? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
- ${PYTHON_DEPS}
-"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
-
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
-
- python-single-r1_pkg_setup
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
-
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
-
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
-
- # Here is where we actually enable ccache
- use ccache && \
- sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
- files/catalyst.conf
-
- sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- files/catalyst.conf
-
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README AUTHORS
- doman files/catalyst.1 files/catalyst-spec.5
-
- python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
- python_optimize "${ED}"
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "https://www.gentoo.org/proj/en/releng/catalyst/index.xml"
-}
diff --git a/dev-util/catalyst/catalyst-2.0.18.ebuild b/dev-util/catalyst/catalyst-2.0.18.ebuild
deleted file mode 100644
index 0bd3e47ff8b5..000000000000
--- a/dev-util/catalyst/catalyst-2.0.18.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-if [[ ${PV} == *9999* ]]; then
- SRC_ECLASS="git-2"
- EGIT_REPO_URI="anongit.gentoo.org/proj/catalyst.git"
- EGIT_MASTER="master"
- SRC_URI=""
- KEYWORDS=""
- S="${WORKDIR}/${PN}"
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- https://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2
- https://dev.gentoo.org/~dolsen/releases/catalyst/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-single-r1 ${SRC_ECLASS}
-
-DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="https://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ccache kernel_linux"
-
-DEPEND="
- app-text/asciidoc
- ${PYTHON_DEPS}
-"
-RDEPEND="
- app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- amd64? ( >=sys-boot/syslinux-3.72 )
- ia64? ( sys-fs/dosfstools )
- x86? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
- ${PYTHON_DEPS}
-"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
-
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
-
- python-single-r1_pkg_setup
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
-
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
-
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
-
- # Here is where we actually enable ccache
- use ccache && \
- sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
- files/catalyst.conf
-
- sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- files/catalyst.conf
-
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README AUTHORS
- doman files/catalyst.1 files/catalyst-spec.5
-
- python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
- python_optimize "${ED}"
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "https://www.gentoo.org/proj/en/releng/catalyst/index.xml"
-}