summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cookiecutter/cookiecutter-1.7.0.ebuild')
-rw-r--r--dev-util/cookiecutter/cookiecutter-1.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/cookiecutter-1.7.0.ebuild b/dev-util/cookiecutter/cookiecutter-1.7.0.ebuild
new file mode 100644
index 000000000000..76f1d784ee90
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-1.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/audreyr/cookiecutter"
+
+SRC_URI="https://github.com/audreyr/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/future-0.15.2[${PYTHON_USEDEP}]
+ >=dev-python/binaryornot-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/whichcraft-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/poyo-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-time-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git )"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+python_test() {
+ py.test || die
+}