summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/drone-cli/drone-cli-0.7.0_p20170620.ebuild')
-rw-r--r--dev-util/drone-cli/drone-cli-0.7.0_p20170620.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/drone-cli/drone-cli-0.7.0_p20170620.ebuild b/dev-util/drone-cli/drone-cli-0.7.0_p20170620.ebuild
new file mode 100644
index 000000000000..4f16bf5598e3
--- /dev/null
+++ b/dev-util/drone-cli/drone-cli-0.7.0_p20170620.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/drone/drone-cli"
+EGIT_COMMIT="9d8dd90e5ba860eecf39972f46c7d0219e575442"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Command-line interface for Drone"
+HOMEPAGE="https://github.com/drone/drone-cli"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="!!<dev-util/drone-0.7"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install -ldflags "-X main.version=${PV}.${EGIT_COMMIT:0:7}" ${EGO_PN}/drone || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/drone
+ dodoc src/${EGO_PN}/README.md
+}