summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/drone-cli/drone-cli-0.7.0_p20170629.ebuild')
-rw-r--r--dev-util/drone-cli/drone-cli-0.7.0_p20170629.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-util/drone-cli/drone-cli-0.7.0_p20170629.ebuild b/dev-util/drone-cli/drone-cli-0.7.0_p20170629.ebuild
deleted file mode 100644
index 8862e79511c4..000000000000
--- a/dev-util/drone-cli/drone-cli-0.7.0_p20170629.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN="github.com/drone/drone-cli"
-EGIT_COMMIT="a785895ab015abd20e4c42da7901492817141e98"
-
-inherit golang-build golang-vcs-snapshot
-
-ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Command-line interface for Drone"
-HOMEPAGE="https://github.com/drone/drone-cli"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-RESTRICT="test"
-
-RDEPEND="!!<dev-util/drone-0.7"
-
-src_compile() {
- pushd src || die
- GOPATH="${WORKDIR}/${P}"\
- go install -ldflags "-X main.version=${PV}.${EGIT_COMMIT:0:7}" ${EGO_PN}/drone || die
- popd || die
-}
-
-src_install() {
- dobin bin/drone
- dodoc src/${EGO_PN}/README.md
-}