summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/elfkickers/elfkickers-3.0a.ebuild')
-rw-r--r--dev-util/elfkickers/elfkickers-3.0a.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-util/elfkickers/elfkickers-3.0a.ebuild b/dev-util/elfkickers/elfkickers-3.0a.ebuild
deleted file mode 100644
index f23d0b5fe818..000000000000
--- a/dev-util/elfkickers/elfkickers-3.0a.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils toolchain-funcs
-
-MY_PN=${PN/elf/ELF}-${PV}
-S=${WORKDIR}/${MY_PN}
-
-DESCRIPTION="collection of programs to manipulate ELF files: sstrip, rebind, elfls, elftoc"
-HOMEPAGE="http://www.muppetlabs.com/~breadbox/software/elfkickers.html"
-SRC_URI="http://www.muppetlabs.com/~breadbox/pub/software/${MY_PN}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~hppa ~mips sparc x86"
-IUSE="doc"
-
-DEPEND="app-misc/pax-utils"
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/respect-CFLAGS-LDFLAGS.patch
- epatch "${FILESDIR}"/create-destdir-path.patch
- epatch "${FILESDIR}"/add-freebsd-elf-defs.patch
- sed -i -e "s:^prefix = /usr/local:prefix = ${D}:" Makefile \
- || die "sed failed"
-}
-
-src_compile() {
- emake CC=$(tc-getCC) all
-}