summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/glib-utils/glib-utils-2.68.4.ebuild')
-rw-r--r--dev-util/glib-utils/glib-utils-2.68.4.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-util/glib-utils/glib-utils-2.68.4.ebuild b/dev-util/glib-utils/glib-utils-2.68.4.ebuild
deleted file mode 100644
index 87fc5fc52d18..000000000000
--- a/dev-util/glib-utils/glib-utils-2.68.4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
-GNOME_ORG_MODULE="glib"
-
-inherit gnome.org python-single-r1
-
-DESCRIPTION="Build utilities for GLib using projects"
-HOMEPAGE="https://www.gtk.org/"
-
-LICENSE="LGPL-2.1+"
-SLOT="0" # /usr/bin utilities that can't be parallel installed by their nature
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
-"
-
-src_configure() { :; }
-
-do_xsltproc_command() {
- # Taken from meson.build for manual manpage building - keep in sync (also copied to dev-util/gdbus-codegen)
- xsltproc \
- --nonet \
- --stringparam man.output.quietly 1 \
- --stringparam funcsynopsis.style ansi \
- --stringparam man.th.extra1.suppress 1 \
- --stringparam man.authors.section.enabled 0 \
- --stringparam man.copyright.section.enabled 0 \
- -o "${2}" \
- http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl \
- "${1}" || die "manpage generation failed"
-}
-
-src_compile() {
- sed -e "s:@VERSION@:${PV}:g;s:@PYTHON@:python:g" gobject/glib-genmarshal.in > gobject/glib-genmarshal || die
- sed -e "s:@VERSION@:${PV}:g;s:@PYTHON@:python:g" gobject/glib-mkenums.in > gobject/glib-mkenums || die
- sed -e "s:@GLIB_VERSION@:${PV}:g;s:@PYTHON@:python:g" glib/gtester-report.in > glib/gtester-report || die
- do_xsltproc_command docs/reference/gobject/glib-genmarshal.xml docs/reference/gobject/glib-genmarshal.1
- do_xsltproc_command docs/reference/gobject/glib-mkenums.xml docs/reference/gobject/glib-mkenums.1
- do_xsltproc_command docs/reference/glib/gtester-report.xml docs/reference/glib/gtester-report.1
-}
-
-src_install() {
- python_fix_shebang gobject/glib-genmarshal
- python_fix_shebang gobject/glib-mkenums
- python_fix_shebang glib/gtester-report
- exeinto /usr/bin
- doexe gobject/glib-genmarshal
- doexe gobject/glib-mkenums
- doexe glib/gtester-report
- doman docs/reference/gobject/glib-genmarshal.1
- doman docs/reference/gobject/glib-mkenums.1
- doman docs/reference/glib/gtester-report.1
-}