summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/heaptrack/heaptrack-9999.ebuild')
-rw-r--r--dev-util/heaptrack/heaptrack-9999.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/dev-util/heaptrack/heaptrack-9999.ebuild b/dev-util/heaptrack/heaptrack-9999.ebuild
index b9572355eb6e..78ccbe37b70d 100644
--- a/dev-util/heaptrack/heaptrack-9999.ebuild
+++ b/dev-util/heaptrack/heaptrack-9999.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake kde.org xdg-utils
DESCRIPTION="Fast heap memory profiler"
-HOMEPAGE="http://milianw.de/blog/heaptrack-a-heap-memory-profiler-for-linux"
+HOMEPAGE="https://apps.kde.org/heaptrack/
+https://milianw.de/blog/heaptrack-a-heap-memory-profiler-for-linux"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS=""
IUSE="+gui test zstd"
-BDEPEND="
- gui? ( kde-frameworks/extra-cmake-modules:5 )
-"
+RESTRICT="!test? ( test )"
+
DEPEND="
- dev-libs/boost:=
- sys-libs/libunwind
+ dev-libs/boost:=[zstd?,zlib]
+ sys-libs/libunwind:=
sys-libs/zlib
gui? (
dev-libs/kdiagram:5
@@ -39,26 +39,35 @@ DEPEND="
RDEPEND="${DEPEND}
gui? ( >=kde-frameworks/kf-env-4 )
"
+BDEPEND="gui? ( kde-frameworks/extra-cmake-modules:0 )"
-RESTRICT+=" !test? ( test )"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # This doesn't exist in libunwind (bug #898768).
+ unw_backtrace_skip
+)
+
+src_prepare() {
+ cmake_src_prepare
+ rm -rf 3rdparty/boost-zstd || die # ensure no bundling
+}
src_configure() {
local mycmakeargs=(
-DHEAPTRACK_BUILD_GUI=$(usex gui)
-DBUILD_TESTING=$(usex test)
- $(cmake_use_find_package zstd Zstd)
+ $(cmake_use_find_package zstd ZSTD)
)
cmake_src_configure
}
-xdg_pkg_postinst() {
+pkg_postinst() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update
fi
}
-xdg_pkg_postrm() {
+pkg_postrm() {
if use gui; then
xdg_desktop_database_update
xdg_icon_cache_update