summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/icemon')
-rw-r--r--dev-util/icemon/Manifest1
-rw-r--r--dev-util/icemon/icemon-3.1.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/icemon/Manifest b/dev-util/icemon/Manifest
index b5fcb5d0914a..1aca7a3ab2fb 100644
--- a/dev-util/icemon/Manifest
+++ b/dev-util/icemon/Manifest
@@ -1 +1,2 @@
DIST icemon-20140102.tar.xz 69212 SHA256 6af68804b554dd55fcd89aae8e4032a70df653dc24cb81aa5a8557c7733cdb34 SHA512 96ffa914fb02f4dfefe489b4a55d62db736d71e0df0e613f7d0135b477449e687919001711661f4892fde6cc0d58267ecfd09dad95a4fff84c4381aba705845e WHIRLPOOL bc5f35dd920a59a69849d1bdf5fd9c6e45ea86f6bd66c3abb050276feba984b3c385afc18a4ce08b58068742af867450ebc4a6e97b9af8d569a2361119012336
+DIST icemon-3.1.0.tar.gz 111139 SHA256 8500501d3f4968d52a1f4663491e26d861e006f843609351ec1172c983ad4464 SHA512 43b5c959cd66fa65cac25994e5b8f26646b49b57405bd80d6ddb12cc7ed5bfeb5f91f5816900883078075685c25159f5a19b3198594027b3a1b8b0c489237b39 WHIRLPOOL f796343ece42fa5c505bd39902d6198177bc4e61c0a888b6dc17cdcb426ce14ec48f3902a23e18f7c64c702eec40cbef990bf3b7dbbd8e38bb42cf04767d9037
diff --git a/dev-util/icemon/icemon-3.1.0.ebuild b/dev-util/icemon/icemon-3.1.0.ebuild
new file mode 100644
index 000000000000..bdf10ab714f8
--- /dev/null
+++ b/dev-util/icemon/icemon-3.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Monitor program for use with Icecream compile clusters based on KDE Frameworks"
+HOMEPAGE="https://en.opensuse.org/Icecream https://github.com/icecc/icemon"
+SRC_URI="https://github.com/icecc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ sys-devel/icecream
+"
+DEPEND="${RDEPEND}
+ app-text/docbook2X
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=OFF
+ )
+ cmake-utils_src_configure
+}