summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lttng-modules/lttng-modules-2.8.0.ebuild')
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.8.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild b/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild
index d7f32b7b99d1..33312ef7bf42 100644
--- a/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild
+++ b/dev-util/lttng-modules/lttng-modules-2.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -33,6 +33,10 @@ pkg_pretend() {
fi
}
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
src_install() {
for i in $(find "${S}" -name "*.ko" -print); do
local val=${i##${S}/}