summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/molecule/molecule-0.9.24.6.ebuild')
-rw-r--r--dev-util/molecule/molecule-0.9.24.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/molecule/molecule-0.9.24.6.ebuild b/dev-util/molecule/molecule-0.9.24.6.ebuild
new file mode 100644
index 000000000000..7f4032dbcc57
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.24.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="*"
+
+inherit python
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/intltool
+ sys-devel/gettext"
+RDEPEND="net-misc/rsync
+ sys-fs/squashfs-tools
+ sys-process/lsof
+ virtual/cdrtools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/molecule"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/molecule"
+}