summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild')
-rw-r--r--dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild b/dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild
new file mode 100644
index 000000000000..38ae56d3d149
--- /dev/null
+++ b/dev-util/ninka/ninka-2.0_pre1_p20170402.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="A license identification tool for source code"
+HOMEPAGE="http://ninka.turingmachine.org/"
+# snapshot of https://github.com/dmgerman/ninka
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ myspell-en_CA-KevinAtkinson public-domain Princeton Ispell"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sqlite"
+RESTRICT="test"
+
+RDEPEND="dev-perl/IO-CaptureOutput
+ dev-perl/Spreadsheet-WriteExcel
+ virtual/perl-File-Temp
+ sqlite? (
+ dev-perl/DBD-SQLite
+ dev-perl/DBI
+ )"
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+# test? (
+# ${RDEPEND}
+# virtual/perl-Test-Simple
+# dev-perl/Test-Pod
+# )"
+# Test::Strict not packaged yet
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-braces.patch
+ "${FILESDIR}"/${P}-makefile.patch
+)
+
+src_compile() {
+ perl-module_src_compile
+ emake -C comments CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ perl-module_src_install
+ use sqlite || rm "${ED}"/usr/bin/ninka-sqlite || die
+ dobin comments/comments
+ doman comments/comments.1
+ dodoc BUGS.org
+}