summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2018.1.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index d3aacaef5aee..4b79a6e00d8e 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1 +1,2 @@
DIST pycharm-community-2017.3.4.tar.gz 279847033 BLAKE2B 451540aae6434f39a94a664d4aa8747071c9c045793a7d445bf1acf4c0412309448b9e05b01c7e86d5b6915d144cb5175956981597d24064b2a7f934bd043bf3 SHA512 0478ca55a0dbd45b54c3d1af45a6cfdc562f0a863e3fe09922421ed121e22f5182c71fbc05b0e9fe7a8e92b197f6ad473da34b30b867297690d7bd9df5fda730
+DIST pycharm-community-2018.1.4.tar.gz 271284732 BLAKE2B 806fb3774f08cd94ea525a3e3a6de3b1a17f1340e093e897ab185b7e08a4f389b627b5f3b5233421ef6c1468f36ec205bfaac73f3b8f151f57c23f0ce44ad3ea SHA512 00040aa0f6d6cc60837277c1413b155b82ec580c6619d425aeb8c50521c11c17654549901a3c324d335d8818120e1e9e730ec03a03722058aa1064685e17cbce
diff --git a/dev-util/pycharm-community/pycharm-community-2018.1.4.ebuild b/dev-util/pycharm-community/pycharm-community-2018.1.4.ebuild
new file mode 100644
index 000000000000..c37c85ebc8eb
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2018.1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon bin/${MY_PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}