summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/qmtest/qmtest-2.4.1-r1.ebuild')
-rw-r--r--dev-util/qmtest/qmtest-2.4.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/qmtest/qmtest-2.4.1-r1.ebuild b/dev-util/qmtest/qmtest-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..faeac0eb7c88
--- /dev/null
+++ b/dev-util/qmtest/qmtest-2.4.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="CodeSourcery's test harness system"
+HOMEPAGE="http://www.codesourcery.com/qmtest/"
+SRC_URI="http://www.codesourcery.com/public/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+ find "${D}" -name config.py -print0 | xargs -0 sed -i "s:${D}:/usr:"
+ rm -r "${D}"usr/share/doc/${PN}/{COPYING,LICENSE.OPL} || die
+ mv "${D}"usr/share/doc/${PN}/* "${D}"usr/share/doc/${PF} || die
+ rm -r "${D}"/usr/share/doc/${PN} || die
+}