summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ragel/ragel-6.9.ebuild')
-rw-r--r--dev-util/ragel/ragel-6.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-6.9.ebuild b/dev-util/ragel/ragel-6.9.ebuild
new file mode 100644
index 000000000000..2f153c15a807
--- /dev/null
+++ b/dev-util/ragel/ragel-6.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools autotools-utils
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code"
+HOMEPAGE="http://www.colm.net/open-source/ragel/"
+SRC_URI="http://www.colm.net/files/ragel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="vim-syntax"
+
+DEPEND=""
+RDEPEND=""
+
+# We need to get the txl language in Portage to have the tests :(
+RESTRICT=test
+
+DOCS=( ChangeLog CREDITS README TODO )
+
+src_test() {
+ cd "${S}"/test
+ ./runtests.in || die
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim
+ fi
+}