summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rr/rr-4.5.0.ebuild')
-rw-r--r--dev-util/rr/rr-4.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/rr/rr-4.5.0.ebuild b/dev-util/rr/rr-4.5.0.ebuild
new file mode 100644
index 000000000000..09413354976f
--- /dev/null
+++ b/dev-util/rr/rr-4.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+CMAKE_BUILD_TYPE=Release
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Record and Replay Framework"
+HOMEPAGE="http://rr-project.org/"
+SRC_URI="https://github.com/mozilla/${PN}/archive/${PV}.tar.gz -> mozilla-${P}.tar.gz"
+
+LICENSE="MIT BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-libs/libpfm
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+
+RDEPEND="
+ sys-devel/gdb[xml]
+ ${DEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}