summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/shards/shards-0.11.0.ebuild')
-rw-r--r--dev-util/shards/shards-0.11.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-util/shards/shards-0.11.0.ebuild b/dev-util/shards/shards-0.11.0.ebuild
deleted file mode 100644
index c36571a58c8e..000000000000
--- a/dev-util/shards/shards-0.11.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-CRYSTAL_MOLINILLO_PV=0.1.0
-CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
-
-DESCRIPTION="Dependency manager for the Crystal language"
-HOMEPAGE="https://github.com/crystal-lang/shards"
-SRC_URI="
- https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz -> ${CRYSTAL_MOLINILLO_P}.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="
- >dev-lang/crystal-0.11.1[yaml]
-"
-RDEPEND="${DEPEND}"
-
-RESTRICT=test # missing files in tarball
-
-src_prepare() {
- default
-
- # bundle crystal-molinillo to bootstrap 'shards'
- mkdir -p lib || die
- ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
-
- tc-export CC
-}
-
-src_install() {
- dobin bin/${PN}
- dodoc README.md
-}