summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild')
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild b/dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild
new file mode 100644
index 000000000000..586567a061dc
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.118.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}