summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/gitolite/gitolite-3.6.2-r1.ebuild')
-rw-r--r--dev-vcs/gitolite/gitolite-3.6.2-r1.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/dev-vcs/gitolite/gitolite-3.6.2-r1.ebuild b/dev-vcs/gitolite/gitolite-3.6.2-r1.ebuild
new file mode 100644
index 000000000000..71c7f88232bf
--- /dev/null
+++ b/dev-vcs/gitolite/gitolite-3.6.2-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+[[ ${PV} == *9999 ]] && SCM="git-2"
+EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_MASTER=master
+
+inherit perl-module user versionator ${SCM}
+
+DESCRIPTION="Highly flexible server for git directory version tracker"
+HOMEPAGE="http://github.com/sitaramc/gitolite"
+if [[ ${PV} != *9999 ]]; then
+ SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+else
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="tools vim-syntax"
+
+DEPEND="dev-lang/perl
+ virtual/perl-File-Path
+ virtual/perl-File-Temp
+ >=dev-vcs/git-1.6.6"
+RDEPEND="${DEPEND}
+ !dev-vcs/gitolite-gentoo
+ vim-syntax? ( app-vim/gitolite-syntax )
+ dev-perl/JSON"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/lib/gitolite git
+}
+
+src_prepare() {
+ echo $PF > src/VERSION
+}
+
+src_install() {
+ local uexec=/usr/libexec/${PN}
+
+ rm -rf src/lib/Gitolite/Test{,.pm}
+ insinto $VENDOR_LIB
+ doins -r src/lib/Gitolite
+
+ dodoc README.markdown CHANGELOG
+ # These are meant by upstream as examples, you are strongly recommended to
+ # customize them for your needs.
+ dodoc contrib/utils/ipa_groups.pl contrib/utils/ldap_groups.sh
+
+ insopts -m0755
+ insinto $uexec
+ doins -r src/{commands,syntactic-sugar,triggers,VREF}/
+ doins -r contrib/{commands,triggers}
+
+ insopts -m0644
+ doins src/VERSION
+
+ exeinto $uexec
+ doexe src/gitolite{,-shell}
+
+ dodir /usr/bin
+ for bin in gitolite{,-shell}; do
+ dosym /usr/libexec/${PN}/${bin} /usr/bin/${bin}
+ done
+
+ if use tools; then
+ dobin check-g2-compat convert-gitosis-conf
+ dobin contrib/utils/rc-format-v3.4
+ fi
+
+ keepdir /var/lib/gitolite
+ fowners git:git /var/lib/gitolite
+ fperms 750 /var/lib/gitolite
+
+ fperms 0644 ${uexec}/VREF/MERGE-CHECK # It's meant as example only
+}
+
+pkg_postinst() {
+ if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
+ ewarn
+ elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
+ elog "Please read http://gitolite.com/gitolite/migr.html first!"
+ fi
+
+ # bug 352291
+ ewarn
+ elog "Please make sure that your 'git' user has the correct homedir (/var/lib/gitolite)."
+ elog "Especially if you're migrating from gitosis."
+ ewarn
+}