summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.9.0.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.9.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.9.0.ebuild b/dev-vcs/hg-git/hg-git-0.9.0.ebuild
new file mode 100644
index 000000000000..96c5e8576a8e
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.9.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_rc/a}
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="https://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="https://foss.heptapod.net/mercurial/hg-git/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-4.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.19.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"