summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-2.6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index a5845d2c69a5..bcbaf1e53339 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1,2 +1,3 @@
DIST fossil-src-2.4.tar.gz 4919205 BLAKE2B 35009cffc757b6ea153faf89525cae4463a2169dace090183b9dd6955a615a04363576295e4b24652ebec7f20772ef9d83c6b9af29f68bd5695c56b88cbf77cb SHA512 de7f2321677df7f6dc2a3a20e58f456602d938f40125ef33d401f28cdaa93e38d3db10e109547df269bc95a2ac8669ade05b6fd6fad39e6633f15ffdd91c499f
DIST fossil-src-2.5.tar.gz 5036719 BLAKE2B b25067ee79793343a017dee28d3ee2b5eb257118a1e334932c6413971f83517ea0cfe570008c35ac4318b52982cb1129ab91eb3380a7f491f09c29cac46a756e SHA512 ee5d8708c91457b7b4d4bada15504e27016a096f0527a81c983c493531d226beb8e4b7aa84b0d764a5404342b8fd2c4dc3196426c9fc8b9c612e1940dd8bde1f
+DIST fossil-src-2.6.tar.gz 5083119 BLAKE2B 7d5cbeb072c72574b9f4fcbc87f9aeaa1db7964f961aa206a04bf64d73782bd6d51f2a19973fa4125969c864031cf78790a67acd32c5e8f209fe1211410a6af4 SHA512 a4f3b2ee696a7f156a295672c17e8ec63737a85cee5d47b1f66a9d45a6011006ed0a075082b5e06e5d75d59babef493d1815ec45f8ae99f42ed1a1c7a2447b1c
diff --git a/dev-vcs/fossil/fossil-2.6.ebuild b/dev-vcs/fossil/fossil-2.6.ebuild
new file mode 100644
index 000000000000..4d67d2ea6c23
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/index.html/uv/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug fusefs json -legacy-mv-rm -miniz system-sqlite +ssl static
+ tcl tcl-stubs tcl-private-stubs th1-docs th1-hooks"
+
+REQUIRED_USE="ssl? ( !miniz )"
+
+DEPEND="
+ sys-libs/zlib
+ || ( sys-libs/readline:0 dev-libs/libedit )
+ system-sqlite? ( >=dev-db/sqlite-3.24.0:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl=1'
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( legacy-mv-rm miniz tcl-stubs tcl-private-stubs
+ th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}