summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/qgit/Manifest1
-rw-r--r--dev-vcs/qgit/qgit-2.8.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/qgit/Manifest b/dev-vcs/qgit/Manifest
index 6f137bb238c6..224c5a645fe9 100644
--- a/dev-vcs/qgit/Manifest
+++ b/dev-vcs/qgit/Manifest
@@ -1 +1,2 @@
DIST qgit-2.7.tar.gz 259624 BLAKE2B 48c5b7bd7da6b037b4be103a7de32375128311200ab98956edb1ac269fd46d6f4ec93049d86ce92fa009999e87bb8df6706f44847f795d993c829ee9d117ce69 SHA512 024fd825aaec64301f0bcbe0ca1d02eb8da0d754d79d09075b1cd87a507d44c97092b824949f2637b37f0e71b36723cad6963cd00dcb2f7597832aba3a5ab842
+DIST qgit-2.8.tar.gz 260236 BLAKE2B eb6dfc83891a8598c31c4711dfcfca1952abfdd8d2e54ce295260674b63bb90ec84fc582f8b045342640e3aed1aab0f000ec89e47a9147e98d1274540a744b2e SHA512 9845064a3f0b2e48b7bb1cbe8f252eaa4e4174cfd2e270ba6c746f0200847ee4d3cdded7f9550849743781669bd7f6f1afe1e83a918b2863a915876b27a3e42a
diff --git a/dev-vcs/qgit/qgit-2.8.ebuild b/dev-vcs/qgit/qgit-2.8.ebuild
new file mode 100644
index 000000000000..fb3be3a163c4
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Qt GUI for git repositories"
+HOMEPAGE="https://github.com/tibirna/qgit"
+SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+ !dev-vcs/qgit:2
+"
+
+S=${WORKDIR}/${PN}-${P}