summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-cola/git-cola-3.11.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-vcs/git-cola/git-cola-3.11.0.ebuild b/dev-vcs/git-cola/git-cola-3.11.0.ebuild
index 1aa8af03490f..ebab708004f6 100644
--- a/dev-vcs/git-cola/git-cola-3.11.0.ebuild
+++ b/dev-vcs/git-cola/git-cola-3.11.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,7 +34,6 @@ BDEPEND="sys-devel/gettext
test? (
${VIRTUALX_DEPEND}
dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-flake8[\${PYTHON_USEDEP}]
dev-python/mock[\${PYTHON_USEDEP}]
dev-python/PyQt5[\${PYTHON_USEDEP},gui,widgets]
)
@@ -58,6 +57,9 @@ python_prepare_all() {
# fix ssh-askpass directory reference
sed -i -e 's/resources\.share/resources\.prefix/' cola/app.py || die
+ # disable flake8 testing, it's not useful for ebuilds
+ sed -i -e 's:--flake8::' pytest.ini || die
+
distutils-r1_python_prepare_all
}