summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-4.6.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 63f5af2dab7c..83b453ab5760 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,3 +1,4 @@
DIST tortoisehg-4.5.2.tar.gz 7935559 BLAKE2B c69107f28767936232937ee0b730b9b937dc1a475d142f0783b59b434072be1b2413f141e02985f3efe09a107782e64411323bd7c0a41be8802b1f23f54fdc77 SHA512 7be831203a33a9d7ea9e3caebb5a4d3f21ff0f07c508926b33b43db39ae11b3533c4274af78cdc2955fbea20f3e4ebe364004c9ad0a781ec7d49c19c2f5a1935
DIST tortoisehg-4.5.3.tar.gz 7929645 BLAKE2B 95b867f372d636ed84eda918a707e24f4b11e34679ae9ed1c25f82a7aa6bb77f424bd68a99b5f961d14960a2f33005536996de2f3df9871684bb53f68130b1b2 SHA512 0c6c512f7a46a084904a5e66912deb8ef4abb99a6a97c46b6b058537332f091395f4b9b8a4b645d7c42637abbb4e8abe16f5040fd694bb43ea8b4c6ddb1e18f6
+DIST tortoisehg-4.6.1.tar.gz 7947844 BLAKE2B 68d0e8672febb9bfdca763e77cbaff8de79c2de79b61e0096c3ef7370cf9d9287a5fd65fbe3c262e13f185bcf5e384ece5d8365979bc05188e74ccfb49f43543 SHA512 adf5ebfc7a76843b62f66feddfde42c0f915c970a951e037f082ee4a6b393822b023f116dc650d5242838d006dc572235a4089c3805929727435588c24ded480
DIST tortoisehg-4.6.tar.gz 7947478 BLAKE2B b2176e3fd508a84c247802490822d47ed117f3102b4ddc10987114018611a710696e2910f3e4b63f80357611fd2ebd8333322df1e5f549a9a618ea1b9017e430 SHA512 a57d3f10dde22da48b03252e41286dd40b7e261ae9ac9a0c09c8ccc361773d9f66ddb0f71c7eb800bfdae65587915a988367472885eb473ee810a07828044ce0
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.6.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.6.1.ebuild
new file mode 100644
index 000000000000..7b53e9b14fbf
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-4.6.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-4.5 <dev-vcs/mercurial-4.7"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.9.4:=[qt5(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${L10N+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${L10N}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ if use doc ; then
+ dohtml -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${ED%/}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
+ || die
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+}