summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/armagetronad')
-rw-r--r--games-action/armagetronad/Manifest1
-rw-r--r--games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild66
-rw-r--r--games-action/armagetronad/files/armagetronad-0.2.8.3.3-gcc6.patch222
3 files changed, 0 insertions, 289 deletions
diff --git a/games-action/armagetronad/Manifest b/games-action/armagetronad/Manifest
index f5e1a88d326a..7555c86c96ef 100644
--- a/games-action/armagetronad/Manifest
+++ b/games-action/armagetronad/Manifest
@@ -1,2 +1 @@
-DIST armagetronad-0.2.8.3.3.src.tar.bz2 1857868 BLAKE2B 60a8fffe61903cb1fa4b188ae6c72ad842e5395b8a37276a6b84018e5393e1294e6ef5438fc7e029d02bfd7172eb81973781e7fbb670c3c7fbacae46d19de409 SHA512 05dd7db10efdac0e681133d07384b0e3c2edea328433f1d906e36b5f70960bf502df8d496967981b6bd67e1a119af9a5bbd71b0c824f790921deb3165165dc3f
DIST armagetronad-0.2.9.1.0.tbz 1943758 BLAKE2B ed4ecef19125d69faf402829b88288124dd364eafc836be3848727c2bfbd87ca29e18b48448dc868fb995947b2daae150c3b9f5dcf048d0d90d442f5bcf425f0 SHA512 8c2b9cba7d480dec6d7d60984327a5d45c8c87b968fb81a1e192973e6826ddb66c8d41ca82bb04d80da5c6fa2152d19dd890957dabc6cc5ce2d4dffbc45d1f65
diff --git a/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild b/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild
deleted file mode 100644
index 8c28621c0f8d..000000000000
--- a/games-action/armagetronad/armagetronad-0.2.8.3.3-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit desktop gnome2-utils
-
-DESCRIPTION="Fast-paced 3D lightcycle game based on Tron"
-HOMEPAGE="http://armagetronad.org/"
-SRC_URI="https://launchpad.net/armagetronad/${PV:0:5}/${PV:0:7}.x/+download/armagetronad-${PV}.src.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="dedicated sound"
-
-RDEPEND="
- dev-libs/libxml2
- !dedicated? (
- media-libs/libpng:0=
- media-libs/libsdl[X,opengl,video,sound?]
- media-libs/sdl-image[jpeg,png]
- virtual/glu
- virtual/opengl
- sound? ( media-libs/sdl-mixer )
- )"
-DEPEND=${RDEPEND}
-
-PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
-
-src_prepare() {
- default
- sed -i -e 's#aa_docdir=.*$#aa_docdir=${docdir}#' configure || die
-}
-
-src_configure() {
- # --enable-games just messes up paths
- econf \
- $(use_enable dedicated) \
- $(use_enable sound music) \
- --disable-sysinstall \
- --disable-useradd \
- --disable-uninstall \
- --disable-games
-}
-
-src_install() {
- default
-
- # misplaced desktop-file/icons
- rm -r "${ED%/}"/usr/share/${PN}/desktop || die
- doicon -s 48 desktop/icons/large/armagetronad.png
- make_desktop_entry ${PN}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-action/armagetronad/files/armagetronad-0.2.8.3.3-gcc6.patch b/games-action/armagetronad/files/armagetronad-0.2.8.3.3-gcc6.patch
deleted file mode 100644
index 0cd6e5bc1d67..000000000000
--- a/games-action/armagetronad/files/armagetronad-0.2.8.3.3-gcc6.patch
+++ /dev/null
@@ -1,222 +0,0 @@
-Bug: https://bugs.gentoo.org/show_bug.cgi?id=617768
-Commit: https://sourceforge.net/p/armagetronad/code/10845/
-
---- a/src/engine/eNetGameObject.cpp
-+++ b/src/engine/eNetGameObject.cpp
-@@ -85,7 +85,7 @@
- eNetGameObject::eNetGameObject(eGrid *grid, const eCoord &pos,const eCoord &dir,
- ePlayerNetID* p,bool autodelete)
- :eGameObject(grid, pos,dir,NULL,autodelete),
--nNetObject(p->Owner()),player(p){
-+ nNetObject(Owner(p)),player(p){
- lastClientsideAction=0;
- if (sn_GetNetState()!=nCLIENT)
- RequestSync();
-@@ -205,7 +205,7 @@
-
- void eNetGameObject::SetPlayer(ePlayerNetID* a_player)
- {
-- tASSERT( !a_player || Owner() == player->Owner() );
-+ tASSERT( !a_player || Owner() == Owner(player) );
- player = a_player;
- if ( laggometerSmooth == 0 && sn_GetNetState() != nCLIENT )
- laggometerSmooth = laggometer = se_GetPing( player );
---- a/src/engine/ePlayer.cpp
-+++ b/src/engine/ePlayer.cpp
-@@ -56,6 +56,7 @@
- #include "nConfig.h"
- #include "nNetwork.h"
- #include <time.h>
-+#include <climits>
-
- int se_lastSaidMaxEntries = 8;
-
-@@ -1689,9 +1690,9 @@
- // foo (Red Team) --> Blue Team: some message here
- eTeam *senderTeam = sender->CurrentTeam();
- console << tColoredString::ColorString(1,1,.5) << " (";
-- console << *senderTeam;
-+ console << senderTeam;
- console << tColoredString::ColorString(1,1,.5) << ") --> ";
-- console << *team;
-+ console << team;
- }
-
- console << tColoredString::ColorString(1,1,.5) << ": ";
-@@ -1923,7 +1924,7 @@
- else {
- eTeam *senderTeam = sender->CurrentTeam();
- say << tColoredString::ColorString(1,1,.5) << " (";
-- say << *team;
-+ say << team;
- say << tColoredString::ColorString(1,1,.5) << " ) --> ";
- say << senderTeam;
- }
-@@ -3941,7 +3942,7 @@
- sg_ClampPingCharity( ::pingCharity );
- }
-
--static int IMPOSSIBLY_LOW_SCORE=(-1 << 31);
-+static int IMPOSSIBLY_LOW_SCORE=INT_MIN;
-
- static nSpamProtectionSettings se_chatSpamSettings( 1.0f, "SPAM_PROTECTION_CHAT", tOutput("$spam_protection") );
-
---- a/src/engine/eTeam.cpp
-+++ b/src/engine/eTeam.cpp
-@@ -31,20 +31,21 @@
- #include "nConfig.h"
-
- #include <set>
-+#include <climits>
-
--tString & operator << ( tString &s, const eTeam & team)
-+tString & operator << ( tString &s, const eTeam * team)
- {
-- if ( !(&team) )
-+ if ( !team )
- return s << tOutput("$player_spectator_message");
- else
-- return s << team.GetColoredName();
-+ return s << team->GetColoredName();
- }
--std::ostream & operator << ( std::ostream &s, const eTeam & team)
-+std::ostream & operator << ( std::ostream &s, const eTeam * team)
- {
-- if ( !(&team) )
-+ if ( !team )
- return s << tOutput("$player_spectator_message");
- else
-- return s << team.GetColoredName();
-+ return s << team->GetColoredName();
- }
-
- #define TEAMCOLORS 8
-@@ -75,7 +76,7 @@
- // static tList<eTeam> se_ColoredTeams;
- static eTeam * se_ColoredTeams[TEAMCOLORS]={0,0,0,0,0,0,0,0};
-
--static int IMPOSSIBLY_LOW_SCORE=(-1 << 31);
-+static int IMPOSSIBLY_LOW_SCORE=INT_MIN;
-
- // class that creates config items for one team
- // TEAM_(NAME|RED|GREEN|BLUE)_X
---- a/src/engine/eTeam.h
-+++ b/src/engine/eTeam.h
-@@ -32,8 +32,8 @@
- #include "nNetObject.h"
- #include "tList.h"
-
--tString & operator << ( tString&, const eTeam&);
--std::ostream & operator << ( std::ostream&, const eTeam&);
-+tString & operator << ( tString&, const eTeam*);
-+std::ostream & operator << ( std::ostream&, const eTeam*);
-
- template<class T> class nConfItem;
-
---- a/src/network/nNetObject.h
-+++ b/src/network/nNetObject.h
-@@ -128,7 +128,16 @@
-
- virtual void Dump( tConsole& con ); // dumps object stats
-
-+ static unsigned short ID(nNetObject const *pThis)
-+ {
-+ if (pThis)
-+ return pThis->id;
-+ else
-+ return 0;
-+ }
-+
- unsigned short ID() const{
-+ tASSERT(this);
- if (this)
- return id;
- else
-@@ -135,7 +144,16 @@
- return 0;
- }
-
-+ static unsigned short Owner(nNetObject const *pThis)
-+ {
-+ if (pThis)
-+ return pThis->owner;
-+ else
-+ return ::sn_myNetID;
-+ }
-+
- unsigned short Owner() const{
-+ tASSERT(this);
- if (this)
- return owner;
- else
---- a/src/tools/tLocale.cpp
-+++ b/src/tools/tLocale.cpp
-@@ -731,6 +731,13 @@
-
- // and a special implementation for the locales and strings:
- tOutput& operator << (tOutput &o, const char *locale){
-+ return o.AddString(locale);
-+}
-+
-+tOutput & tOutput::AddString(char const * locale)
-+{
-+ tOutput & o = *this;
-+
- int len = strlen(locale);
- if (len == 0)
- return o;
---- a/src/tools/tLocale.h
-+++ b/src/tools/tLocale.h
-@@ -81,7 +81,7 @@
-
- tOutputItemBase *anchor;
-
-- tOutput& operator << (const tOutput &o);
-+ // tOutput& operator << (const tOutput &o);
- public:
- tOutput();
- ~tOutput();
-@@ -91,6 +91,7 @@
- void AddLiteral(const char *); // adds a language independent string
- void AddLocale(const char *); // adds a language dependant string
- void AddSpace(); // adds a simple space
-+ tOutput & AddString(char const * pString); // checks the string, delegates to correct Add...()-Function
-
- // set a template parameter at this position of the output string
- tOutput & SetTemplateParameter(int num, const char *parameter);
-@@ -113,7 +114,7 @@
-
- SetTemplateParameter(1, template1);
-
-- *this << identifier;
-+ AddString(identifier);
- }
-
- template< class T1, class T2 >
-@@ -125,7 +126,7 @@
- SetTemplateParameter(1, template1);
- SetTemplateParameter(2, template2);
-
-- *this << identifier;
-+ AddString(identifier);
- }
-
- template< class T1, class T2, class T3 >
-@@ -138,7 +139,7 @@
- SetTemplateParameter(2, template2);
- SetTemplateParameter(3, template3);
-
-- *this << identifier;
-+ AddString(identifier);
- }
-
- template< class T1, class T2, class T3, class T4 >
-@@ -152,7 +153,7 @@
- SetTemplateParameter(3, template3);
- SetTemplateParameter(4, template4);
-
-- *this << identifier;
-+ AddString(identifier);
- }
-
- tOutput(const tOutput &o); // copy constructor